「WordPress」カテゴリーアーカイブ

SI CAPTCHA Anti-SpamプラグインはGDが必要

CAPTCHA anti-spamはWordPressにコメント入力画面やログイン画面に画像認証を付記するプラグインなのですが、GDが必要な事に気づきました。しかもインストール後。

エラー: si-captcha.phpプラグインによると、PHPにGD image supportが見当たりません!
PHPにGD image supportが有効になっていない理由については、サーバ管理者にお問合せください。
エラー: si-captcha.phpプラグインによると、PHPにimagepng機能が見当たりません!
PHPにimagepng機能が有効になっていない理由については、サーバ管理者にお問合せください。

エラーメッセージがちゃんと日本語で表示されます。素晴らしい。

と、関心してる場合ではなく、慌ててyumでGDをインストールしました。

# yum -y install gd php-gd

GDインストール後はhttpdのリロードが必要になります。再起動(restart)する必要はありません。

# /etc/rc.d/init.d/httpd reload